先日、あるブログを運用中のWordPressを更新したところ、突然、以下のようなエラーメッセージが表示され、真っ白画面に。

WodPress自体にもログインもできなくなってしまった。

Fatal error: Arrays are not allowed in class constants in /home/XXXXXXXX/ABCDEFG.info/public_html/wp-content/plugins/oo-associate-post-r2/classes/class-omazon.php on line 2
(イメージ図)

エラーメッセージでそのまま簡単にググってみると、どうも、利用中のサーバのPHPのバージョンが古すぎるらしい。

 

思えば、このサイト、どこのサーバーを利用してたかな?という馬鹿馬鹿しい疑問がw
しかしネットでコレも簡単に調べられますね。( https://www.aguse.jp/)

 

自分のサイトのURLを打ち込んで、検索して見ると「エックスサーバー」である事が判明。

ここまで分れば、簡単に見つけられます。

 

ささっとエックスサーバーのコントロールパネルから、PHPのバージョンをエックスサーバー推奨のものに バージョンアップしました。

すると、エラーメッセージが表示されたページはリロードしただけで通常画面に戻りました。

一瞬、どきっとしましたが、簡単に解決できて良かったです。(・∀・)

 

writer: ハラユル浜口